Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Touch Control 2 not working with iConnectMidi2+ and Ableton

Ian Taylor Oct 21, 2014 07:33AM CEST


I have Ableton 9.1.5 on a windows 8 machine, an iPad 2 running ios7 and iConnectMidi 2+. Live is receiving MIDI (I can see the signal indicator. I've installed Touch Control 2 v2.1.3 and I can get the notes on the 'Play' page of Touch Control 2 to trigger notes in Ableton. However, the rest of the interface doesn't seem to work and I don't receive updates to the Launch page to see clips etc. (I had a similar problem with the 2tracks template as it only sent but didn't receive midi.)

I've followed your install instructions and set the control surface to LiveControl 2.1.3, the midi in to Track On and the midi out to sync.

I've also followed these instructions...

Do I need any other software running? I assume as I'm using iConnectMidi2+ that it should be enough? Pretty exasperated with all the configuration but just can't get it to work.

Grateful for help.

Up 0 rated Down
Liine Support Oct 21, 2014 03:06PM CEST Liine Agent

Make sure that you are running the correct version of LiveControl 2:

For Live 9.1.3 and above, use LiveControl 2.1.31
For Live Live 8.4+ or Live 9.1.2 use LiveControl 2.1.3
For all previous versions of Live 9 use LiveControl 2.1

All available here as downloads:

After that, it's a case of having the MIDI settings properly configured in Ableton / Preferences / MIDI Sync, as well as in Lemur. A typical configuration would be:

Control Surface: LiveControl 2 1
Input: Daemon Input 0
Output: Daemon Output 0

MIDI Target 0
Input: Daemon Output 0
Output: Daemon Input 0

With the iConnect MIDI, use the port configurations described here:

Hope that gets you up and running!
Up 0 rated Down
Ian Oct 22, 2014 05:15AM CEST
Thanks for the quick reply. I'm using it wired via iConnectMidi2+ so do I need to use the Daemon? I thought that was just for wireless?

Also, I was using the wrong version. It now works except for the clip updates on Lemur. No clips are added to Touch Control 2 despite showing in Ableton. All MIDI control is fine however.

Up 0 rated Down
Ian Oct 22, 2014 06:46AM CEST
ps I checked iConnectivity's iConfig app and SysEx messages weren't enabled on the port filters. I enabled them but still no luck. What kind of messages are used to send clip information to Lemur? There are other types of events that I could try switching on.
Up 0 rated Down
Ian Oct 22, 2014 04:03PM CEST
SOLVED: The iConnectMidi2+ has sysex messages switched off by default. These must be switched on using iConfig on the Port Filters page - then committed to Flash under the Device menu.
Up 0 rated Down
Liine Support Oct 23, 2014 03:02PM CEST Liine Agent
Hi Ian

Great, happy to hear you've solved that one. We'll make a note of it at our end too, so that we can get this advice out to others that need it.


This question has received the maximum number of answers.
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
Invalid characters found